Xenomai 2.6.0 sur Ubuntu 12.04

Publié par cpb
Mai 02 2012

Xenomai 2.6.0 sur Ubuntu 12.04J’ai vérifié hier que Xenomai 2.6.0 (la dernière version stable à ce jour) s’installe bien sur la nouvelle distribution Ubuntu. Pas de souci, il suffit de procéder comme pour la distribution précédente (voir cet article) en utilisant ce fichier de configuration pour le noyau Linux 2.6.38.8.

3 Réponses

  1. Sebastián dit :

    Salut!

    Je suis un étudiant chilien et je dois realizer une application de temps réel en utilisant Xenomai. J’ai aucune experience avec Linux et surtout moins avec Xenomai. Néanmoins, j’ai utilisé votres explications pour Ubuntu 11.10 en utilisant la configuration que vous mencionez ici. J’ai arrivé à installer Xenomai (je crois) mais quand je choisis “Ubuntu, avec Linux 2.6.38.8-xenomai” dans le Grub l’écran reste noire et l’ordinateur ne respond pas. J’ai choisis donc l’alternative “Ubuntu, avec Linux 2.6.38.8-xenomai (mode de récupération)” et je peux acceder à Ubuntu et compiler les bibliothèques et executer les tests, mais je dois toujours acceder avec cet mode, où l’ordinateur a l’air instable. Donc, je vous demande un conseil et de l’aide si vous êtes possible.
    Merci beaucoup pour votre temps, et désolé pour mon francais.

  2. achille dit :

    Bonjour,

    Je suis étudiant en master informatique à paris, J’ai configuré xenomai sur ubuntu 12.04 comme vous l’avez décrit. Mais lors du démarrage après avoir choisi “previous linux version”—>”ubuntu xenomai 2.6.38.8″, l’écran affiche alternativement un fond noir ou la page de connexion au système. Après quelques minutes un message s’affiche me disant que les composant graphiques ne sont pas bien installés.

    Que faire à ce niveau, pouvez-vous m’aider? Merci d’avance

    Cordialement
    Achille

    • cpb dit :

      Bonjour,
      Apparemment le serveux Xorg n’arrive pas à démarrer. Je suppose qu’il s’agit d’un problème avec des drivers propriétaires qui ne sont pas compatibles avec la version 2.6.38 de Linux.
      Il serait peut-être intéressant d’utiliser une version plus récente de la distribution, du noyau et de Xenomai. Il y a plus de chances que les drivers soient supportés.

URL de trackback pour cette page